26.07.2009

Using Eclipse with Oracle's application server 11g (Weblogic)

JDeveloper 11g is fully integrated with Oracle Weblogic 11g (that is what everybody has expected). Now i tried to connect Eclipse to Oracle's new application server.
This was not easy, so here the steps, if you really want to stay with Eclipse....
  1. Do a right click on the server tab and use the link Download additional server adapters:
  2. After hitting the next button, i got the following error:
    org.eclipse.jst.common_core.... missing
  3. So i installed the missing plugins via ->help->install new software:
  4. But after this upgrade the installation of the Oracle Weblogic server plugins stills failed ;-(
  5. So i googled around and found this page.
    1. Select Help > Install New Software.
    2. Click Add to add a new update site.
    3. In the Add Site dialog, enter http://download.oracle.com/otn_software/oepe/galileo, and then click OK.
    4. Select Oracle Enterprise Pack for Eclipse, verify that all of the subcomponents are selected, and then click Next.
    5. Confirm information presented in the Install Details, and then click Finish.
  6. So next try:

After that you can choose inside the "new server wizard" Oracle Weblogic 10 or 11:



It works, but there is at least one big difference between JDeveloper and Eclipse: No SOA or BPEL extension is available for Eclipse...



1 Kommentar:

  1. Hi,

    I guess there are no embedded weblogic standlone server available like what we have for Jdeveloper with embedded OC4J?

    AntwortenLöschen