13.05.2018

Ubuntu 16.04: Installation of chrome-browser fails with libnss3 (>= 2:3.22)

On my old laptop with ubuntu 16.04 i tried to install "chrome-browser":
# dpkg -i google-chrome-stable_current_amd64\ \(1\).deb 
Vormals nicht ausgewähltes Paket google-chrome-stable wird gewählt.
(Lese Datenbank ... 137351 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von google-chrome-stable_current_amd64 (1).deb ...
Entpacken von google-chrome-stable (64.0.3282.186-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von google-chrome-stable:
 google-chrome-stable hängt ab von libnss3 (>= 2:3.22); aber:
  Version von libnss3:amd64 auf dem System ist 2:3.21-1ubuntu4.

dpkg: Fehler beim Bearbeiten des Paketes google-chrome-stable (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) werden verarbeitet ...
Rebuilding /usr/share/applications/bamf-2.index...
Trigger für gnome-menus (3.13.3-6ubuntu3) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu5) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 google-chrome-stable

But as you can see, this does not work ;-(
So let's clean up the installation:
# apt-get install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden Pakete werden ENTFERNT:
  google-chrome-stable
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 148 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 186 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] 
(Lese Datenbank ... 137451 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von google-chrome-stable (64.0.3282.186-1) ...
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) werden verarbeitet ...
Rebuilding /usr/share/applications/bamf-2.index...
Trigger für gnome-menus (3.13.3-6ubuntu3) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu5) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
Several searches via google did not help.

But after a while i recognized, that chromium-browser is integrated into ubuntu. With this knowledge was easy:
# apt install chromium-browser
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libappindicator1 libcurl3 libdbusmenu-gtk4 libindicator7
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden Installiert
  chromium-browser-l10n chromium-codecs-ffmpeg-extra
Vorgeschlagene Pakete:
  webaccounts-chromium-extension unity-chromium-extension adobe-flashplugin
Die folgenden NEUEN Pakete werden installiert:
  chromium-browser chromium-browser-l10n chromium-codecs-ffmpeg-extra
0 aktualisiert, 3 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 70,8 MB von 71,7 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 287 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]         
Holen:1 http://de.archive.ubuntu.com/ubuntu xenial/universe amd64 chromium-browser amd64 49.0.2623.108-0ubuntu1.1233 [67,5 MB]
Holen:2 http://de.archive.ubuntu.com/ubuntu xenial/universe amd64 chromium-browser-l10n all 49.0.2623.108-0ubuntu1.1233 [3.355 kB]
Es wurden 42,6 MB in 7 s geholt (5.541 kB/s).                                                                          
Vormals nicht ausgewähltes Paket chromium-codecs-ffmpeg-extra wird gewählt.
(Lese Datenbank ... 137350 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../chromium-codecs-ffmpeg-extra_49.0.2623.108-0ubuntu1.1233_amd64.deb ...
Entpacken von chromium-codecs-ffmpeg-extra (49.0.2623.108-0ubuntu1.1233) ...
Vormals nicht ausgewähltes Paket chromium-browser wird gewählt.
Vorbereitung zum Entpacken von .../chromium-browser_49.0.2623.108-0ubuntu1.1233_amd64.deb ...
Entpacken von chromium-browser (49.0.2623.108-0ubuntu1.1233) ...
Vormals nicht ausgewähltes Paket chromium-browser-l10n wird gewählt.
Vorbereitung zum Entpacken von .../chromium-browser-l10n_49.0.2623.108-0ubuntu1.1233_all.deb ...
Entpacken von chromium-browser-l10n (49.0.2623.108-0ubuntu1.1233) ...
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) werden verarbeitet ...
Rebuilding /usr/share/applications/bamf-2.index...
Trigger für gnome-menus (3.13.3-6ubuntu3) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu5) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.15-0ubuntu1) werden verarbeitet ...
chromium-codecs-ffmpeg-extra (49.0.2623.108-0ubuntu1.1233) wird eingerichtet ...
chromium-browser (49.0.2623.108-0ubuntu1.1233) wird eingerichtet ...
chromium-browser-l10n (49.0.2623.108-0ubuntu1.1233) wird eingerichtet ...


Keine Kommentare:

Kommentar veröffentlichen