07.04.2018

Ubuntu: unmet dependencies gparted (libparted-fs-resize0 (>= 3.1))

After a new ubuntu installation i got the following error:
root@pc:/etc/apt/sources.list.d# apt install   gparted
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.   
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 gparted : Hängt ab von: libparted-fs-resize0 (>= 3.1) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
or
The following packages have unmet dependencies:
 gparted :
Depends: libglibmm-2.4-1c2a (>= 2.42.0) but 2.39.93-0ubuntu1 is to be installed
 Depends: libparted-fs-resize0 (>= 3.1) but it is not installable
 Depends: libparted2 (>= 3.1) but it is not installable
 Depends: libstdc++6 (>= 4.9) but 4.8.2-19ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.


I tried some solutions like
apt clean
or removing many repositories out of /etc/apt/sources.list and /etc/apt/sources.d but the error still remained.

After some tries i found the solution via these commands:

The installation of libparted-fs-resize0 does not work with the following error:
root@pc:/etc/apt# apt install libparted-fs-resize0
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.     
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libparted-fs-resize0 : Hängt ab von: libparted2 (= 3.2-15) aber 3.2-15ubuntu0.1 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
So i checked this package:

root@pc:/etc/apt# apt-cache policy libparted2
libparted2:
  Installiert:           3.2-15ubuntu0.1
  Installationskandidat: 3.2-15ubuntu0.1
  Versionstabelle:
 *** 3.2-15ubuntu0.1 100
        100 /var/lib/dpkg/status
     3.2-15 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
Hmmm. 2 Versions inside my versions-table. So i removed the local status file:
root@pc:/etc/apt# cd /var/lib/dpkg/
root@pc:/var/lib/dpkg# mv status status.180227
root@pc:/var/lib/dpkg# touch status
And after that the problem was gone:
root@pc:/var/lib/dpkg# apt update
root@pc:/var/lib/dpkg# apt install gparted
Here we go:


Kommentare: