01.11.2016

Debian dist-upgrade 5 (lenny) to 6 (squeeze): insserv: exiting now

After several years i decided to upgrade my old laptop to the current debian version.
The first
apt-get dist-upgrade
ran into the following problem:
insserv: warning: script 'K01hotplug-net' missing LSB tags and overrides
insserv: warning: script 'K01x2goserver' missing LSB tags and overrides
insserv: warning: script 'K01oracle-xe' missing LSB tags and overrides
insserv: warning: script 'S85vpnagentd_init' missing LSB tags and overrides
insserv: warning: script 'S02vpnclient_init' missing LSB tags and overrides
insserv: warning: script 'S15initrd-tools.sh' missing LSB tags and overrides
insserv: warning: script 'S15hotplug' missing LSB tags and overrides
insserv: warning: script 'S15modutils' missing LSB tags and overrides
insserv: warning: script 'modutils' missing LSB tags and overrides
insserv: warning: script 'hotplug' missing LSB tags and overrides
insserv: warning: script 'initrd-tools.sh' missing LSB tags and overrides
insserv: warning: script 'hotplug-net' missing LSB tags and overrides
insserv: warning: script 'vpnclient_init' missing LSB tags and overrides
insserv: warning: script 'x2goserver' missing LSB tags and overrides
insserv: warning: script 'oracle-xe' missing LSB tags and overrides
insserv: warning: script 'vpnagentd_init' missing LSB tags and overrides
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service vpnagentd_init and rc.local if started
insserv:  loop involving service rc.local at depth 23
insserv:  loop involving service vpnagentd_init at depth 1
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/util-linux_2.20.1-5.3_i386.deb (--unpack):
 Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/util-linux_2.20.1-5.3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Hmmm. A further try with
apt-get dist-upgrade -f
 failed with the same error. What was wrong?
insserv: Starting vpnagentd_init depends on rc.local and therefore on system facility `$all' which can not be true!
 I just searched for "vpnagentd_init" in /etc und found it in /etc/init.d. Quick workaround: I moved the vpnagentd_init in a backup directory and after that the upgrade worked without any problem...

Keine Kommentare:

Kommentar veröffentlichen